How to Install older extention for Firefox 3.5

Firefox已经升级到最新的3.5版本,暂且不论是不是启动速度和页面渲染都变快(实际上我并没有感觉出来 Orz),以前可以使用的一些扩展如果作者没有及时更新的话,在新版本下就无法安装了。

比如Scrapbook这样优秀的扩展,如果无法使用的话简直是一种折磨。

通过以下的方法可以将旧版本的扩展从Mozilla Addons的官方网站上直接安装到Firefox 3.5中。

1. 安装MR Tech Toolkit扩展,该扩展除了自己的强大功能之外,还可以允许其它扩展安装的时候,跳过版本验证步骤。安装完毕以后,将该扩展功能选项中“Enable AddOn Compatibility Checking”之前的勾取消,如下图。

2. 在Mozilla Addons站点注册一个免费的用户,登录之后,才可以在安装扩展的页面上看到“Ignore version check”这样的字样,点击它,本来不允许安装的按钮将变为绿色的“Add to Firefox”。如下图。

3. 像之前一样安装,然后重启Firefox,就可以正常使用扩展了。

2 thoughts on “How to Install older extention for Firefox 3.5

  1. @Jinghao.li
    自然平时还是检查的好,这个只是作为应急手段。
    是可以改,需要有下载到本机的xpi文件,然后winrar打开,直接修改其中的install文件,将maxversion什么的改为现在的ff版本,再重新打包回xpi中。

Leave a Reply

Your email address will not be published. Required fields are marked *